Ça faisait longtemps que je me traînais ça...

Il y a un bon moment, j'ai remarqué que l'ordinateur de Séverine ne pouvait être accédé par le réseau pour le partage de fichier, d'imprimantes, etc.

J'avais fini par résoudre une partie de ces problèmes en configurant le firewall correctement. Norton Internet Security refuse de faire confiance aux connexions réseaux par défaut, et il faut les autoriser à la main. Soit.

Mais ça ne résolvait pas mon problème. Dès que je voulais accéder à cette machine par le réseau, je me prenais ça dans la face :

L'utilisateur ne bénéficie pas de du type d'ouverture de session demandé sur cet ordinateur.

J'avais pourtant tous les utilisateurs créés des deux côtés, avec les mêmes identifiants, et tout. J'ai même ajouté mon nom d'utilisateur dans le groupe administrateurs, sans résultat. C'était même pire encore, il y avait moins de choses qui marchaient (j'avais plus accès à l'imprimante).

En cherchant sur le net, j'ai trouvé une solution plausible : la politique de sécurité locale. Dans Outils d'administration, il y a Stratégie de sécurité locale, et là-dedans, sous Stratégies locales, dans Attribution des droits utilisateur, il y a une règle Accéder à cet ordinateur depuis le réseau.

Et normalement, il y a juste les groupes par défaut, Tout le monde, ASPNET, Administrateurs, Utilisateurs, Utilisateurs avec pouvoir, Opérateurs de sauvegarde. Donc normalement, faisant partie du groupe administrateur, je devrais pouvoir accéder à la machine. Mais non. Séverine non plus.

J'ai donc supposé qu'il y avait quelque chose de pourri dans cette machine. Et je me suis dit que la mise à jour vers Vista corrigerait le problème. Mais non.

Hier, je devais imprimer mes confirmations de réservation de vol pour la Corée (j'en parlerai plus tard), et ma machine ne pouvait pas, parce que celle de Séverine refusait l'accès. Je devais donc résoudre mon problème. Et j'aime pas me traîner les problèmes.

Et hier soir, je suis retombé sur toutes les solutions potentielles que j'avais vues bien avant, que j'ai essayé sans succès. Jusqu'à tomber sur un mec qui dit qu'il faut vérifier aussi la règle Refuser l'accès à cet ordinateur à partir du réseau...

Et en effet, presque tout le monde était dedans... Administrateurs, Séverine, Utilisateurs...

Et en enlevant tout ça, hop ça marche tout de suite. Parce que Windows applique les règles refuser en priorité. S'il y a une règle qui dit "oui" et la même qui dit "non", Windows prend le "non". C'est comme ça.

Par contre, ce qui me dépasse, c'est COMMENT cette règle s'est modifiée ainsi ? J'ai JAMAIS touché à ça, moi, sinon j'y aurais pensé beaucoup plus tôt et je ne me serais pas emmerdé ?!

We use cookies

Nous utilisons des cookies sur notre site web. Certains d’entre eux sont essentiels au fonctionnement du site et d’autres nous aident à améliorer ce site et l’expérience utilisateur (cookies traceurs). Vous pouvez décider vous-même si vous autorisez ou non ces cookies. Merci de noter que, si vous les rejetez, vous risquez de ne pas pouvoir utiliser l’ensemble des fonctionnalités du site.